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Instructions ©J.S. Bowers 1994-1997
Rev.  3/12/97
These instructions are directed toward users of DivvyUP version 1.1 and later.  Any questions,
comments, or suggestions can be made by email to the author at jsbowers@kagi.com 

DivvyUP is SHAREWARE.  Please try DivvyUP for 30 days, and if you decide you want to use it, 
send me $25 to legally register your copy of DivvyUP.  I'll send you a serial number to register
your copy of DivvyUP.  DivvyUP is NOT FREE, and any use beyond the evaluation period is a 
violation of copyright.  Think of the fee as a small compensation for the hours and hours of 
personal labor I put into this time saver for you!  Enjoy!

See the README file that accompanies the program for more details on registration. 

Please distribute unregistered, unaltered versions of DivvyUP to your friends!  

Any commercial distribution is restricted.  Please contact the author for permission.

Send me email telling me ways you use the program, and ways I can improve it.  If you don't 
register your copy, tell me why you don't like it!

Check out the DivvyUP website at http://www.mindspring.com/~laughing/divvyup.html

Thanks for trying DivvyUP!!!
J.S. Bowers

now, on with our show....
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Introduction
Have you ever found yourself planning a new semester, juggling 
groups of students, rooms to put them in, and instructors to teach 
them?  Often times, two courses are scheduled in the same room at 
overlapping times, an instructor is scheduled to teach two courses at 
once, or a group of students is told they must choose between two 
equally important courses held at the same time.  In order to catch all 
of the potential conflicts on paper, you might have found yourself 
pulling your hair out!

Enter DivvyUP, helping you develop a conflict-free list of courses for 
any given semester.  

DivvyUP is a course scheduling calculator.  It helps to develop a list of
courses for a department or school that include common elements 
such as instructors, spaces (rooms), classes of students, and more.  
DivvyUP looks for any conflicts among these elements and alerts the 
user to them.

YOU and your helpful feedback and contributions will encourage me to
continue this project and update the software as the need arises.

If you are dissatisfied with my effort and you don't care to let me 
know, then please quietly drag the application into the trash and 
forget about it.

If you LOVE it, GREAT!!  Let me know by writing me an email and 
paying your registration fee!   See the paragraph at the top of the 
manual for details.
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THE BASICS:

The Nutshell

Basically, DivvyUP is a schedule calculator.  You create courses in the 
schedule, giving them a time and day of the week.  Then you specify a
room, instructor, and other information that you'd like to keep track 
of.  DivvyUP tells you IMMEDIATELY if the room, instructor or other 
item conflicts with another course that you've scheduled.  That way 
you can update the schedule as soon as the conflict is discovered!

Installing DivvyUP

This is the easy part!

Simply find a nice cozy place on your hard drive, drag the "DivvyUP 
folder" icon to that place, and BINGO!  You're ready to go.

DivvyUP requires:

A Macintosh or Power Macintosh computer (or compatible, Mac 
Plus or later)

A Hard drive
1 MB of disk space
MacOS System 7.0 or later
1MB of available application RAM

Getting Started - Opening DivvyUP for the 
first time:

When you open DivvyUP for the first time, you 

1. Double-click the application icon.

Use Word 6.0c or later to           

view Macint osh p icture.             

3



2. A dialog will appear asking for you to save a NEW Element file.
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3. Specify the name and location of the new file.
***Once you have opened an element file for the first time, it will 

open automatically each time you run DivvyUP.
4. A brand new Schedule file window will be opened for you, at which 
point you are ready to begin scheduling.

Making a schedule:
1. Click in the schedule window.

This is the window that automatically appears to the left of the 
Element Window.  It is also the window that appears when you choose "NEW"
from the file window.

2. Choose Add from the Edit menu.
Use Wor d 6.0 c or late r to           

view M acinto sh pictur e.             

This will add a course (in sorted order) to the schedule.
A dialog box will open asking you to give vital information about 
the course.  This is called the "Detail" view of the course.
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3.  Go through and add all of the vital information about a course to
the detail (tabbing between fields).  
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4.  Click on "SET" to set the time and day the course will be 
scheduled.

5.  Fill out the space (room), instructor, and class (freshmen, 
sophomore, etc.).  These items are your ELEMENTS.  Since they 
must be kept track of in the element file, you will be required to 
verify each one of them by either setting up a new record in the 
element file, or selecting an already existing one from the 
element file.

NOTE:  Each one of the "Elements" are the factors that you do not 
want to conflict between courses.  For example, you would not 
expect an instructor to teach two courses that were given at the 
same time, nor would you expect a room to be scheduled for 
two different courses at the same time, nor would you expect a 
class (or group) of students to be in two different places at once.
KEEP THIS IN MIND, because this is how the logic of the 
application works.  DO NOT fill out the class field for fun, but 
only if you MUST require ALL of the "Freshmen" (or whatever 
moniker you choose) to be attending the course.  That way, if 
you schedule the "Freshmen" to be in another place at the same
time, the application will alert you.

5.  When you TAB from any of the element fields, the conflict 
window will BEEP to alert you that there is a conflict in the 
schedule.

6.  Click OK to save the changes you have made to the course 
entry, or click CANCEL to abort those changes.

Saving your work:
1. Element files do NOT need to be saved.  They are maintained for

you by the application.
2. To Save a Schedule file, select the Schedule's Window and 

Choose Save from the File Menu.
3. If you want to save it in a different location or under a different 

name, choose Save As...
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The Element File and The Schedule File:

When using DivvyUP, you will encounter two different types of files:  
The Schedule file and the Element file.  

• The Schedule file: The Schedule file is a schedule for courses in 
the Semester you are planning.   This is the file you will be 
working with the most, printing out when you are done, etc.

• The Element File: The Element file contains all of the elements in
your department, such as the instructors, spaces, and classes of 
students.   Elements and the Element file are saved and updated
automatically, so you generally will not have to worry about 
them.  After you have specified the name and location of where 
your element file is saved, DivvyUP takes care of saving the 
element file and keeping track of it. 

Creating a NEW Element File:
When you begin for the first time, you will want to create and save a 
NEW element file.  If you are using DivvyUP for the first time on this 
computer, then when you start the Application:

1. A dialog will appear asking for you to choose a name and a 
location for a New Element file.

2. Specify the name and location of the new file.
NOTE: The element file specified will open automatically when you 

open the application again.  The Element file is meant to store 
commonly used instructor names, room (space) names, and 
Classes.

Chances are, however, that you ran the application many times before
getting entirely too frustrated, quit, and then came running to these 
instructions.  Therefore, if DivvyUP has already been run a few times 
on this machine, then:

1. Choose New Element File from the Elements menu to create a 
new Element file.

2. Specify the name and location of the new file.
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Creating a New Schedule file:
1. After having either created a NEW element file, or opening an 

older one, Choose NEW from the File menu.
2. An untitled, empty window will open.
 

Adding New Courses to your Schedule file:
1. After opening or creating a Schedule file, Click on the Schedule 

file window. 
2.  Choose INSERT From the Edit menu.
3. An empty Course dialog Detail will open and you will be able to 

fill in the necessary information.
4. Click either OK to close the dialog and add it to the Schedule 

file, or Cancel to forget the course you have started to fill out.

Removing Courses from your Schedule file:
1. Select the unwanted Course by clicking on it (the course will be 

highlighted).
2. Choose Remove from the Edit menu.   OR press the delete 

(backspace) key.
NOTE:  Currently, this action is permanent.

That's the basics, now on to the more 
complicated stuff:

Opening Schedule files:

1. Simply choose Open from the File menu.
2. Or you can double click on the Schedule file's icon in the Finder. 

DivvyUP will be opened and so will the Schedule file.
NOTE: You cannot open or create a Schedule file without first 

opening or creating an Element file.
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Closing Schedule files:

1. Simply close the Schedule file's window.

Changing Elements:

1. Select the Element that you want to change by clicking on it (the
Element will be highlighted).

2. Choose Show Detail from the Edit menu.
3. A dialog will open, allowing you to see the Element and change 

its attributes.
4. Choose OK to close the dialog and modify the changes that you 

have made, or Choose Cancel to close the dialog and ignore 
your changes.

Changing Courses:

1. Select the Course that you want to change by clicking on it (the 
Course will be highlighted).

2. Choose Show Detail from the Edit menu.
3. A dialog will open, allowing you to see the Course and change its

attributes.
4. Choose OK to close the dialog and modify the changes that you 

have made, or Choose Cancel to close the dialog and ignore 
your changes.

Every course that you schedule has a time that it occupies.  We call 
this its "time slot".  A time slot is based on a weekly schedule, with 
both days of the week and times of the day.
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Here is an example of a time slot window:
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<Each of the checkboxes represent a day of the week, and the times represent the 
time on those days.  Therefore, the above box is Monday, Wednesday, and Friday at 
9:25AM-11:30AM or MWF 9:25AM-11:30AM>

Conflicts:  how to create them and how to 
avoid them.
A conflict occurs when you assign the same element to two separate 

courses at the same time.  Conflicts will appear in the course's 
Conflict Window Within the conflict's detail window.  

When you create a course, you set up the course's time slot.  By doing
this and selecting certain elements  to be included with this 
course, you tie up the elements for that time slot.  If another 
course tries to put itself into that time slot, then there will be a 
conflict.

Importing Text files from other applications
Export the data from the other application in tab - delimited format.  
For an example of tab-delimited format, please see the accompanying 
demo import file.  This file was created by exporting data from 
DivvyUP’s export function.

1.  Open a new or existing schedule file.
2.  Choose “IMPORT” from the file menu.
3.  locate the file that you will be importing from.
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4.  You will now see the import dialog box.  You will be able to 
match up fields in DivvyUP with the data in the text file by 
dragging the fields up or down.  If you do not want a field to 
import, click on the arrow next to the field to make it disappear.

5.  You can scroll through the file using the arrow buttons in the 
dialog box, in order to see all of the data in the import file.

6.  Choose import when you have matched up all of the data 
correctly.

7.  The imported data should now be in the schedule file

Adjusting Columns

1.  Click on the area near the edge of a column in the header 
(where the names of the columns appear)

2.  A line will appear, and you will be able to drag the column wall 
to the desired width.

3.  To make a column disappear, make it really narrow.
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D E F I N I T I O N S

Element file: The file that contains all of the Instructors, Classes, 
and Spaces that you will include in any course lists 
that you create.  
• For example, you would have a single element file 
containing your whole faculty, all of the rooms that 
you schedule classes into, and the names of all of 
the groups of students you schedule (freshmen, 
sophomores, seniors).

Schedule file: The files that contain lists of courses with common 
elements.  
• For example, you would have a Schedule file for 
FALL 96, containing all of the courses scheduled for 
the fall semester.

Conflict: When an element is scheduled to be in two different 
places at the same time, this is a CONFLICT.  
Conflicts appear in the course’s show detail dialog 
(double click the course).  When a course has a 
conflict, it will be shown as bold in the schedule.

------------------------------------------------------------------------
DivvyUP: Course Scheduling Software is copyright 1994-1997 by J.S. Bowers.  Any distribution 
must include all original documentation.  The software is SHAREWARE; please see the 
documentation above and README file for details.  Any commercial distribution or sale is 
restricted, and must be approved by the author.

DISCLAIMER:
  DivvyUP is being distributed on an "as is" basis.  The author shall not be liable, to the least 
possible extent under law, for losses incurred through the use or malfunction of this program.
  If, after paying the registration fee, you are dissatisfied with this program in any way, 
contact me, and after receiving a full refund, delete this program and associated files.
  If any of these terms are not acceptable to you, then do not use this program.

I hope you like it and it works well for you.
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